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Trademarks
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and VDO Wave are trademarks of VDOnet Corp. Ltd.
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materials are used for identification purposes only and may be trademarks
or registered trademarks of their respective owners. Registered and
unregistered trademarks used in any VDOnet products and materials are
the exclusive property of their respective owners.
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About this Chapter
Begin with this chapter to gain a general understanding of VDOLive
technology and products.
Information in this chapter is organized by topic, as follows:

n Introduction to Desktop Video Broadcasting: presents an overview of
how VDOnet’s VDOLive technology and products enable you to
communicate in a new medium called Desktop Video Broadcasting.

n What’s Special About VDOnet’s VDOLive Technology: describes
the technological advantages of VDOLive technology and the complete
process you follow to use VDOLive products.

n VDOLive Family of Products: explains when to use each of the
VDOLive products and what to use it for.

n About This Manual: defines the visual cues used to help you quickly
locate information in this manual.

n Support for VDOLive Customers: lists the various types of support
available.
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Introduction to Desktop Video Broadcasting
Now that you have the VDOLive Tools you can broadcast your video
content to the world of Internet users. Using this software you can bring
life to your personal or corporate web pages by adding clips with video and
sound.
But enhancement of web pages, whether for advertising, educational or
other purposes, is only one of the numerous applications of VDOLive. By
bringing together Internet and video communications, VDOLive is creating
a new communications medium: desktop video broadcasting.
Desktop video broadcasting means richer, more interesting communications
for individual as well as corporate users. Motion video can be made easily
available to friends, colleagues and customers who view the video using
their regular Internet connection. VDOLive offers you motion to replace
static information and real-time streaming video from a VDOLive Server
instead of lengthy download times.
Beyond the limitations of current technology lies a world in which
community meetings, interaction between citizens and government, between
educational institutions and students, and numerous other such forms of
interaction will become possible using video communications over the
Internet. VDOnet has taken a giant step towards making this happen by
offering products that work at both high and low bandwidths and on
multiple platforms. Continuing development by VDOnet in these areas will
soon bring additional products to your desktop.
Watch the VDOnet web site (http://www.vdo.net) for announcements of
future technology breakthroughs and new products from VDOnet!
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What’s Special About VDOLive Technology
VDOLive technology enables you to incorporate video and audio in
Internet web sites and efficiently delivers video over a variable bandwidth
computer network, such as the Internet, using:

n Efficient and scalable compression algorithms.
n A TCP/IP based scalable transmission protocol.
VDOLive also offers direct delivery of video from the web site to the user’s
screen, without downloading! This means:

n less waiting
n no risk of contamination by viruses
VDOLive is a software-only solution and requires no additional hardware.

How Does it Work?
You can reach a wide audience with your video content by using VDOLive
products as follows:

n Capture and compress your video and audio using the VDOLive Tools.
n Store the compressed AVI clips on the VDOLive Server computer.
n Create a text file that points from your Web (HTTP) Server to the
VDOLive Server. See separate document: Making your VDOLive
Content available on the WWW for guidelines.

n Create an HTML link from your web page to the VDO file. See also:
Making your VDOLive Content available on the WWW.
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When your viewers access your web site, they see full-color motion video
by clicking on the links you have provided. There are no lengthy waits for
downloading.

n Viewers use the VDOLive Video Player to request and play your
video files.
Your VDOLive Server sends compressed data over a TCP/IP connection
and the VDOLive Video Player decodes and displays the video. The
TCP/IP network is usually the Internet, but could also be a LAN, intranet
or any other TCP/IP network.

Scalability
We define “scalability” as the dynamic adjustments made by the VDOLive
Server in order to deliver the highest quality video under changing
conditions, i.e. variable bandwidth.
Each time a VDOLive Video Player, also called a “client”, connects to a
VDOLive Server to request video, the Server determines the bandwidth
available in that particular connection. For as long as the client remains
connected the VDOLive Server performs “dynamic scaling”.
Scalability is built into the compressed file. The scalability of the
compressed data combined with the VDOLive Server’s dynamic scaling,
provides the best possible video quality at any particular moment.

Compression Efficiency
Compression of video and audio data is necessary in order to minimize the
bandwidth required to efficiently transmit this data. The better the
compression, the faster the data can travel over narrower lines.
The VDOLive compression algorithms are highly efficient. They enable the
transmission of higher quality video than other compression schemes at any
11
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given bandwidth: even as low as 14.4 kilobits per second (kbps)! VDOLive
compression works together with the VDOLive Server’s scalability to
adjust the rate of transmission to the bandwidth available on the receiving
end, while preserving the best possible balance of motion and resolution for
the connection.

VDOLive Family of Products
The VDOLive product line includes the following software:

n
n
n
n
n

VDOLive Video Server
VDOLive Broadcast Server
VDOLive Capture Station
VDOLive Tools
VDOLive Video Player

The VDOLive Tools are available as part of a VDOLive Video Server
package and are also available separately. To purchase additional copies of
the VDOLive Tools, contact VDOLive Corp. Sales by telephone, at
(415) 846-7730 or via the VDOnet web site: http://www.vdo.net.

About the VDOLive Video Server
Use the VDOLive Video Server to:

n Store files of compressed video and audio data.
n Serve video to users upon request by a VDOLive Video Player (also
called a “client”).

About the VDOLive Tools
Use the VDOLive Tools to prepare video files.
12
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The VDOLive Tools include two separate programs: VDO Capture and
VDO Clip.

n Use VDO Capture to convert video from an analog source, such as
video cassettes, to digital format.
n Use VDO Clip to compress digital (i.e. previously captured) video.

About the VDOLive Video Player
The VDOLive Video Player is the VDOLive client software. Your
audience requires this Player to view VDOLive video. Download the
Player, for free, from VDOnet’s web site at http://www.vdo.net.
Although the Player is not covered in this manual, you can learn more
about it by consulting the Frequently Asked Questions (FAQ) file on the
VDOnet web site: http://www.vdo.net.
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About This Manual
This manual uses typographical conventions and other visual cues, in
addition to chapter divisions, to help you find the information you want.

Visual Cues
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Type Used

For…

Italics

NAMES of: windows, files, buttons, options or paths.

Bold

Emphasis within text, such as terms used for
the first time.

Shaded Text

Tips

Monotype

Examples of initialization files,
source code, etc.

Bold Monotype

User Input

SMALL CAPS

NAMES OF KEYBOARD BUTTONS/FUNCTIONS
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Chapter Summaries
The information in this manual is divided into six chapters:

n Welcome to VDOLive: begin by reading this chapter to get a general
understanding of what VDOLive technology is all about, what the
various products are and how they work together. If you are already
familiar with VDOLive, and are looking for how-to information about
the Tools, proceed to the following chapters.

n Trial Version Tools: this chapter defines the functioning of the free
version of the VDOLive Tools.

n Introduction to the VDOLive Tools: defines technical requirements
and provides installation instructions.

n VDO Capture: defines features and explains how to use the capture
tool. A detailed table of contents for this section is found on page 23.

n VDO Clip: defines features and explains how to use the compression
tool. A detailed table of contents for this section is found on page 42.

n Appendices: look here for troubleshooting information and tips.
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Support for VDOLive Customers
Tips in this Manual
Look for text printed on a shaded background. Any useful tips on using
VDOLive products, or related advice, are identified this way throughout
the manual.

Support on the World Wide Web
The VDOnet web site (http://www.vdo.net) includes a Technical Support
section with how-to information, tips on using VDOLive products and a
Technical Notes section. Access the Technical Support area of the VDOnet
web site from the home page.
Check the VDOnet web site often for current information and news!

Online Help
Both VDO Capture and VDO Clip include online help files you can turn to
while using these programs. They include definitions and explanations of
the functions available in each tool.
Access the online help from the main menu bar of the program.

16

Trial Version Tools

Tr ial Ver s ion Tools
If you downloaded the VDOLive Tools for trial purposes from the VDOnet
web site, you have a Trial Version.
The Trial Version Tools are capable of:
Compressing :

n up to 1 minute of video and/or audio data.
n at a maximum video encoding rate of 128 kbps.
n in any of the 4 VDOLive compression modes; Lite VDO
encoding is not supported.
n only from VDO Clip, not from any other application.
Additional Limitations:

n the Trial Version Tools expire on April 30, 1997.
n VDO Clip:
n File|Driver Options leads directly to Compression
Configuration window.
n SaveAs can save only as original format.
n Only way to compress is in VDOLive format, using
VDOEncode command.
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Intr oduc tion to VDO Live Tools
The VDOLive Tools include a capture tool, called VDO Capture, and a
compression tool, called VDO Clip.
The following chapters document the features and uses of these tools,
including the following topics:

n Introduction to VDOLive Tools: introduces you to the VDOLive
Tools and their functionality.

n Technical Requirements: lists software and hardware requirements for
using the VDOLive Tools.

n Installing VDOLive Tools: covers operating instructions for setting up
the VDOLive Tools on your computer.

n VDO Capture: provides instructions for using VDO Capture and
guides you through functions, features and operations.
A Table of Contents for this section appears on page 23.

n VDO Clip: provides instructions for using VDO Clip and guides you
through functions, features and operations; includes explanations of
editing and compression features in VDO Clip.
A Table of Contents for this section appears on page 42.
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Technical Requirements
Minimum System Requirements
Following is the minimum system configuration required for both the
Capture and the Compression Tool. Additional information about capture
hardware is listed on page 24.

n Processor: 486
n Operating System: Windows 95 operating system
–or–
Windows NT 3.51 or 4.0, Server or Workstation

n RAM: 16 MB
n Available Disk Space: 1.2 MB to complete the installation. (additional
disk space required for storing captured and/or compressed files)

Additional hardware required for capture:
n Source of video/audio for capture, such as:
n Camera, or
n VCR / VTR with video/audio out.
The quality of the source video is an important factor in the quality of the
compressed video. We recommend using Beta SP format.

n Video Capture Card compatible with your operating system. See
page 24 for additional details.
n Sound Card with supporting drivers.
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Installing VDOLive Tools
Uninstalling previous versions
Remove any installation of the VDOLive Personal Tools 1.0 or earlier
before installing this version of the Tools. Running the VDOLive Personal
Tools 1.0 or earlier after the full version of the VDOLive Tools have been
installed results in the codec drivers being uninstalled. The VDOLive
Tools must to be reinstalled in order for them to function properly.
If you installed the VDOLive Personal Tools 1.0 or earlier to the default
directory, use any uninstall option to remove them before installing this
version of the VDOLive Tools.

Ø

If you installed the VDOLive Personal Tools 1.0 or earlier to any directory
other than the default installation directory, use the custom uninstall option
to remove the Personal Tools before installing this version.
To uninstall the VDOLive Tools:
1. Select Uninstall from the folder or program group of the version of the
Tools you are removing.
2. Choose either the Automatic or the Custom uninstall option.
Automatic uninstall removes program and related data files from the
hard disk but does not remove general purpose DLL files such as the
video and audio codec drivers. These DLLs may be of use with other
VDOnet products.
Custom uninstall allows you full control over the uninstall process and
prompts you to decide which, if any, program components, including
DLLs, you remove from your system.
3. Follow on screen instructions until uninstall is complete.
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Installing this version of the VDOLive Tools

Ø

To install the VDOLive Tools:
1. Uninstall the VDOLive Personal Tools 1.0 or earlier.
2. Run the VDOLive Tools installation executable file by double clicking
on it.
3. Follow the on screen instructions.

Uninstalling

Ø

To remove the VDOLive Tools from your system:
1. Select Uninstall from the VDOLive Tools folder or program group.
Alternatively, on Windows 95, select Add/Remove Programs from the
Control Panel(Start|Settings|ControlPanel) and select VDOLive Tools.
2. Choose either the Automatic or the Custom uninstall option.
Automatic uninstall removes program and related data files from the
hard disk but does not remove general purpose DLL files such as the
video and audio codec drivers. These DLLs may be of use with other
VDOnet products.
Custom uninstall allows you full control over the uninstall process and
prompts you to decide which, if any, program components, including
DLLs, you remove from your system.
3. Follow on screen instructions until uninstall is complete.
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VDO Captur e

About the Capture Tool
Use VDO Capture software to capture from analog video, such as VHS or
Beta SP magnetic tapes, and from analog audio, to digital format. The
conversion process requires use of a video capture card together with VDO
Capture, and a sound card if audio is to be captured as well. VDO Capture
is not an editing tool.
Proper configuration of your capture card and its drivers is necessary in
order for VDOLive Tools to work. Refer to your capture card
documentation for details.
If capture functions are not working properly, try capturing using any
capture program that may have come with your capture card, and/or with
VidCap, the Microsoft video capture application for Video for Windows. If
the functions do not work in either application, check that your capture
hardware and drivers are installed properly.

22

VDO Capture

Using the Capture Tool
Capture cards that work with VDOLive................................................................... 24
Hardware Dependent Functions............................................................................. 25
What you can do to improve Capture Results ........................................................ 26
Adjusting the sound input ....................................................................................... 27
Setting up Files....................................................................................................... 28
Defining Files .............................................................................................................. 28
Allocating File Space................................................................................................... 29
How to calculate the amount of space to allocate ...................................................................29

Checking and Changing Capture Settings.............................................................. 31
Supported Video Formats....................................................................................... 34
Supported Audio Formats....................................................................................... 35
Using MCI Control of Source Video........................................................................ 36
Starting Capture ..................................................................................................... 37
Stopping Capture ................................................................................................... 38
Copying to the Clipboard ........................................................................................ 39
Importing a Palette ................................................................................................. 39
Creating a Palette................................................................................................... 40

23

VDOLive Tools version 2.1

Technical Requirements Specific to VDO Capture
Capture cards that work with VDOLive
Please refer to the VDOnet web site (www.vdo.net) for a list of capture
cards that work with VDOLive.
Your capture card must support the following operations in order to work
with VDO Capture:

n Color depth of 16 bits per pixel (RGB 555) or 24 bits per pixel (RGB
888). 8 bit color is supported, but not recommended for use. 32 bit
color is not supported.

n To capture motion video, your capture card must be able to support a
capture rate of 15 frames per second (fps). To capture video for use in
flip mode, a capture rate of 2 fps is sufficient.

n Capture of raw (uncompressed) video
– or –

n Capture and compression to a Microsoft Video for Windows™
compatible format.
Capture cards that compress to MPEG, Motion JPEG or other proprietary
compression schemes, are not supported for use with VDO Capture.

Ø

To capture data using these cards and other capture software and
still compress them using VDOLive compression:
1. Use the Ulead MPEG Converter™ to convert directly from MPEG
to VDOLive format.
–or–
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2. Save the data as an uncompressed AVI file before opening it in
VDO Clip. This usually requires you to use another program that
supports the compression format of your file.

Hardware Dependent Functions
The following functions in the Options menu of VDO Capture of are
available only if supported by your capture hardware.

n Preview / Overlay: Your capture hardware may support one or both of
these functions. Only one mode can be active at a time.

n Preview video: preview sets the VDO Capture screen area to
display images of captured video during the capture process,
according the frame rate you set. If, for example, you are
capturing at 15 frames per second, in preview mode, 15 frames a
second of captured video are displayed on screen. Using Preview
gives you a relatively good idea of what the captured video looks
like, however, it uses CPU resources.
n Overlay video: this is a hardware-only function which does not
require any CPU resources. When you are set to overlay mode,
the video you see is being sent directly from the capture hardware
to your screen. It does not reflect the quality of the captured
video. If your capture hardware supports Overlay, use this option
to minimize the load on your processor.
n Video Format: defines dimensions of captured video and color depth
(in bits per pixel).

n Video Source: defines video input channels; type of input signal
supplied by video source. Parameters such as hue, brightness and
contrast.
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n Video Display: defines appearance of video on screen during capture.
(Does not affect appearance of captured video).

Before you begin Capturing
What you can do to improve Capture Results
Some of the operations you can perform to improve capture results include:

n Increasing the amount of RAM on your system.
n

Upgrade your processor.

n Maximize Windows memory by restarting Windows before running
VDO Capture
–or–
run VDO Capture before opening or running any other Windows
applications.

n Removing programs from your Windows Startup group also
helps.
n Optimize/Defragment your hard disk. This reduces the frequency of
dropped frames as well as time needed to open and save files.

n Capture to an internal IDE or SCSI disk. External IDE disks connected
to the parallel port are not well suited for video capture.

n Check for drivers from previously installed capture hardware, or
external disk drives, no longer in use. Removing these drivers can help
improve the smoothness of your captured video.

n Make sure the drivers you are using for your video and sound cards are
the most current ones available. Contact the card manufacturer for
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additional information; current information and drivers are frequently
available on the company’s web site.

n Use a utility such as Norton Disk Doctor™ to check your hard disk
before beginning capture.

Adjusting the sound input

Ø

Before you capture, necessary to adjust the sound input for optimum
recording level. You can do this using Windows 95 tools, or using the
Goldwave application (page 51).
To adjust the sound input using Goldwave:
1. Open a new empty file.

Ø

2. Refer to the Goldwave documentation for details on how to monitor the
input level and make adjustments in the Windows 95 “Recording
Control” window as described in the following procedure.
To adjust the sound input using Windows 95 tools:
1. Restart your computer.
2. Open both the Windows 95 Volume Control (double-click on the
loudspeaker icon at the bottom right corner of your desktop) and the
Sound Recorder (Start | Programs| Accessories| Multimedia).
3. Open the Options menu of Volume Control. Select Properties, then and
select Recording in the area labeled Adjust volume for.
4. In the area labeled Show the following volume controls, check all the
check boxes if they are not already checked. Click “OK”. The window
is now labeled Recording Control (instead of Volume Control).
5. Select the type of audio input you are using. If, for example, you are
going to be capturing from a video cassette, select Line-In or
27
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Microphone, according to the location of the connection you are using
in the back of the computer.
6. Begin playing the video you plan to capture. It’s best to play a
particularly loud selection.
7. Watch the audio intensity meter in the Recording Volume column of the
Recording Control window.
If the audio intensity meter does not display anything, stop the video, press
the Sound Recorder record button (the red dot at the far right) and play the
video again. The audio should register now.
8. The clearest audio will display bright green and yellow bars in the audio
intensity meter. Red indicates some distortion. Replay your video and
adjust the Volume slider in the appropriate input column of the
Recording Control window until there is as little distortion as possible.
9. Close the Sound Recorder (if prompted to save, choose No) and the
Recording Control.

Setting up Files
Defining Files

Ø

To create the file to which you store captured data:
1. Choose Set Capture File from the File menu
–or–
from the Options menu, choose Capture Settings, and then Set File in
the Capture Settings dialog box.
A dialog box opens.
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2. In the Set Capture File dialog box, name the file and define its location.
Use the .avi extension for the file name.
3. Click Open.
If you do not set up a file before capturing, your data will be saved to a file
named capture.avi under the root directory of your local disk (c:\).
Capture to your local disk! Capturing to a network drive may result in a
high percentage of dropped frames, especially at higher capture rates.

Allocating File Space
Set aside disk space before beginning capture to achieve a higher number
of successfully captured frames than without pre-allocation of disk space.
If your data exceeds the space you allocated, the file will enlarge
automatically as necessary, however, the advantage of pre-allocation is lost
when this happens. Therefore, you may want to allocate about 20% more
space than you expect to need. If this results in your file being larger than
necessary, because of space allocated which has no data in it, follow the
procedure listed below (page 31) for removing empty space from a file.
How to calculate the amount of space to allocate
Calculate the amount of disk space you should allocate as follows:
Total Bytes Required = Bytes required for video + Bytes required for
audio, where:
[width of frame (pixels) * height of frame (pixels) * bits per pixel] divided
by 8 = bytes per frame

29

VDOLive Tools version 2.1

# of bytes per frame* # of frames per second * length of planned capture
(seconds) = Bytes for video
16KB per second of audio = Bytes for audio

Sample Calculation

n Image (Frame) Size: 160x120
n Color Depth:

24 bits per pixel

n Capture Rate:

15 frames per second

n Total capture time: 30 seconds
160 pixels wide x 120 pixels high = 19200 pixels per frame
19200 pixels per frame x 24 bits per pixel=460800 bits per frame
460800 bits per frame divided by 8=57600 bytes per frame
57600 bytes per frame x 15 frames per second = 864000 bytes per second
864000 bytes per second x 30 seconds of video = 25920000 bytes required
for video
(25,920,000 bytes = 25,312.5 KB or 24.72MB)
Audio: 16 KB per second x 30 seconds = 480 KB required for audio
Total Disk Space Required: 25,312.5KB (video) + 480KB (audio) =
25,792.5 KB or 25.19 MB.
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Ø

To allocate file space:
1. Choose Allocate File Space from the File menu. The Set File Size
dialog box opens.
2. In the dialog box, enter the number of megabytes of your disk you are
setting aside for this file.
3. Click OK.

Removing empty space from a file
To remove empty space from a file:

Ø

1. Open the file in VDO Clip.
2. In Driver Options, set the video compression to Full Frames
(Uncompressed).
3. Set Audio Format to the same format as in the original file (where
“original” refers to the file from which you are removing the space).
4. Use Save As to save the file under a different name.
The original file is not overwritten in this process; you are actually creating
a new file. Since uncompressed data files are large, discard the original file
(the one with the empty space) once you have created the new file to
prevent your disk from filling.

Checking and Changing Capture Settings

Ø

To view, define or change capture settings:
1. Choose Capture Settings from the Options menu. The Capture Settings
dialog box opens:
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Figure 1 - Capture Settings Dialog Box of VDO Capture
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Define or change the settings as necessary, as follows:
To define or change:

Do this…

Capture Frame Rate

Enter a number in the Frame Rate box.
This is the number of frames per second
(fps) at which video is captured.
Capture at 10-18 fps for best results.

Capture Time Limit

Enter a number in the Enable Capture
Time Limit box. Capture is timed in
seconds.

Capture Audio

Check this box to capture audio together
with video.
Uncheck to capture video only.

File Name for Captured
Data

Click on the Set File button.

Video Format

Click on the Video button to open the Set
Video Format dialog box.

Audio Format

Click on the Audio button to open the Set
Audio Format dialog box.

MCI Control of Source
Video

Use MCI Device Settings from the
Options menu.
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Supported Video Formats

Ø

To view, define or change video format settings:
1. Click on the Video button in the Capture Settings panel to open this
dialog box:

Figure 2 - Capture Settings: Set Video Format

Supported Capture Formats: 16 bit and 24 bit color.

n Video in 16 bit color must be in RGB 555 format
n

Video in 24 bit color must be RGB 888.

Work with 24 bit color for best results.
Supported Image Sizes:
If you plan to compress the captured data using VDO Clip, the minimum
image dimensions supported are 64 x 64.
Maximum size supported by VDOLive compression
pixels (w) * 288 (h) (CIF)
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n Maximum size 16 bit VDOLive Video Player can play:
240 pixels (w) * 176 (h)

n Maximum size 32 bit VDOLive Video Player can play:
352 pixels (w) * 288 (h) (CIF)

n Maximum recommended image size for movie mode:
240*176
For movie mode clips intended for Internet delivery to users with modem
connections (28.8 kbps or less) use 160*120.

n Maximum recommended image size for flip mode:
352*288

n Maximum recommended image size for storybook mode:
352*288
However, for such large frames, do not put in more than one frame each
10 seconds. For a faster frame rate, decrease the frame size.
If you are not sure what size to use, we recommend 160x120.

Supported Audio Formats

Ø

To view, define or change audio format settings:
1. Click on the Audio button in the Capture Settings panel to open this
dialog box:
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Figure 3 - Capture Settings: Set Audio Format

Supported Sample Size: 16 bit
Supported Channels: Mono
Supported Frequency: 8 kHz
Only these audio settings are supported by VDO Capture and VDO Clip.
Any data captured by VDO Capture can be compressed using VDO Clip.
If you are using any program other than VDO Capture to capture audio,
use one that supports audio capture at 8 kHz. A method of “converting”
audio from unsupported formats to the 8 kHz format supported by VDO
Clip involves use of additional software, however, it will make this data
available for use with VDOLive compression. See the section on
“Converting Audio from an Unsupported Format” beginning on page 51.

Using MCI Control of Source Video
If you are working with professional level video equipment, you may wish
to use this convenient and precise method of controlling source video. You
36

VDO Capture

Ø

must have a physical connection between your video source hardware and
your computer as well as the appropriate MCI device driver installed. MCI
related options in VDO Capture is disabled in the menu if you do not have
the required configuration.
To enable MCI control of source video:
1. Choose MCI Device Settings from the Options menu and enter the
necessary settings.
2. Return to the Options menu of VDO Capture and choose Capture
Settings.
3. Check the MCI Control of Source Video checkbox.
The MCI area is now active. You can define time codes here and use the
button bar in this area to control the video source.

Capturing
Starting Capture

Ø

To begin capturing, follow these steps:
1. Set up your file as described in Setting up Files, above.
2. Start playing your source video.
Video should appear in the window of VDO Capture. If no picture
appears, check the following:

n Is the VCR or other device on?
n Is it playing?
n Is it connected properly? Check the Source Connector setting in
Options|Video Source option to see that it is defined properly. It
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should be set to the type of connector (S-Video or Composite)
you are using.
Refer to the Troubleshooting your Equipment section (Appendix A, page
101) for more help.
3. Choose Capture Video from the Capture menu.

Ø

Since it is difficult to hit the exact frame at which you want capture to start
and end, we recommend starting capture a bit before where you want your
clip to start, and stopping capture a bit after the end. The extra frames can
be edited out later.
To remove the extra frames from your captured video:
1. Open the file in VDO Clip.
2. Highlight each frame or range to be deleted.
3. Use Cut or Delete to remove the frames.
See the section beginning on page 48 for an explanation of editing
functions available in VDO Clip.

Stopping Capture

Ø

To stop capture:
1. Use the left mouse button
–or–
use the ESCAPE key.
There may also be a stop capture function defined by your capture card
software; see your capture card documentation for this information.
If you do not stop capture, it can continue until your disk is full.
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Prevent your disk from filling during capture by setting a time limit.
Capture will stop automatically when this limit is reached. Define the
capture time limit in the Capture Settings dialog box (Options|Capture
Settings).
Various statistics, as determined by your capture card drivers, may be
displayed when capture is complete.

Copying to the Clipboard

Ø

To copy one video frame to the Clipboard:
1. Position the frame you wish to capture in the VDO Capture window.
2. Choose Copy from the Edit menu. The displayed frame is copied to the
Clipboard as a Device Independent Bitmap (DIB).

Working with Palettes
When working with a 256 color display, use a palette in order to see color;
otherwise the picture is displayed in gray scale. You can import a palette
from an application other than VDO Clip or create one.

Importing a Palette

Ø

To import a palette:
1. Place a palette from any application on the Clipboard.
2. Choose Paste Palette from the Edit menu.
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Creating a Palette

Ø

To create a palette:
1. Choose Make Palette from the Options menu. The Create New Palette
dialog box opens.
2. Define the number of colors (1-236 or 1-256).
3. Define the number of frames from which you want the colors to be
sampled.

Defining Image Size and Quality

Ø

To define or change the size of the captured video frame and its quality:
1. Choose Video Format from the Options menu.
2. Select from the options available in the dialog box.

Making Color Adjustments

Ø

To make adjustments to the color in your captured video:
1. Choose Video Source from the Options menu
2. Make any changes in the dialog box that opens.

Tuning Video Display

Ø

To tune the quality of your video display:
1. Choose Video Display from the Options menu
2. Make your adjustments in the dialog box that opens.

40

VDO Capture

Exiting the Capture Tool

Ø

To close the program and exit from VDO Capture
1. Choose Exit from the File menu.
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About the Compression Tool
Use VDO Clip to edit and compress previously captured, uncompressed
video and audio and encode this data using VDOLive technology. The
compressed files, saved in .avi format, are ready for transmission by the
VDOLive Video Server over any TCP/IP network.

Using the Compression Tool
Viewing Clips ................................................................................................................ 45
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When to use Audio Programs ............................................................................................... 77
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Switching to the Capture Tool

Ø

At any time, you can open the capture tool without closing the compression
tool.
To open VDO Capture from VDO Clip:
1. Choose Capture from the File menu.
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Viewing Clips
Opening a Clip

Ø

Use the File|Open command to open any multimedia file in VDO Clip, such
as files in .avi or .wav format.
To open a file:
1. Select Open from the File menu. The Open AVI dialog box opens.
2. Browse for the file and click on the Open button. The clip appears in
the VDO Clip window:
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Figure 4 - VDO Clip with open .avi file

The clip is now available for viewing, editing, compressing and saving.
Files that are not multimedia, such as bitmaps, cannot be opened in VDO
Clip using the File|Open command. This type of data can be pasted in from
other applications and will be displayed in the main window of VDO Clip.

Playing a Clip
You can play files of uncompressed or compressed video.
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Playing from the Play menu

Ø

To play a clip:
1. Open the .avi file you want to play.
2. Select Play from the Play menu.
You can do any of the following once the clip is playing:
To …

Do this …

Stop

Use the Stop Play command from the Play menu

Go directly to the
beginning of the clip

Press the HOME key

Go directly to the end
of the clip

Press the END key

Restart once the clip
has reached the end

Press the HOME key

Scroll through a clip

Use the slider at the bottom of the window, or use
the keyboard arrow keys to move one frame at a
time.

Playing from the MCI Player

Ø

To play a clip from VDO Clip using the MCI Player:
1. Select Play|MCI Player.
2. Select Open and enter the name of the file you wish to play.
You can play VDOLive compressed video using the MCI Player on any
computer where the VDOLive drivers are installed. The drivers are
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included in the installation of the VDOLive Tools and can be installed
separately, without the capture and compression tools.

Zooming

Ø

To change the size of the picture displayed on your screen:
1. From the Zoom menu, select the magnification you want:
/4 = one-quarter image size
/2 = one-half image size
x1 = actual captured or compressed image size
x2 = twice image size
x4 = four times image size

Editing Clips
Ordinarily when you work in movie or flip mode, your source material will
be an .avi file containing both an audio and video stream. However,
whether to create an audio program or merge an audio stream into a
storybook, or to edit any clip, you can merge an audio stream into an open
video clip or video data into an audio clip. For instructions, see page 51.
Edit only uncompressed data.

Editing Video and Audio
Editing, for the purposes of work using VDO Clip, means manipulating the
order of the information in an audio or video stream. The editing functions
are listed under the Edit menu of VDO Clip and include Cut, Copy, Paste
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and Delete. Use these functions to rearrange the sequence of video frames,
to remove portions of the data in a stream or to add data to a stream.
Select the data to be edited in order to enable the editing functions;
selecting, for the purposes of editing in VDO Clip, means highlighting
using a selecting function. Methods of selecting data are explained below.
Edit only uncompressed data.

Ø

To edit video or audio data:
1. Select (highlight) the video frames or the portion of the audio stream
you want to edit (see chart following). You can select video or audio
together or separately.
2. Apply any of the standard editing functions from the Edit menu. These
functions (Cut, Copy, Paste and Delete) remain disabled until data has
been selected.
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The following chart tells you how to select the data you want to edit.
To…

Do This…

Select one video frame

Click on frame.

Select one video frame,
with corresponding
portion of audio stream

SHIFT+Click on video frame

Select a range of video
frames

Click on start frame
SHIFT+Click on stop frame.

Select a whole stream
(video or audio)

Click at the top border of the stream.

Select a range of video
frames, with
corresponding portion of
audio stream

CTRL+click on start frame in video
SHIFT+CTRL+click on stop frame in video

Although it is possible to apply these instructions to the audio stream first,
you may find it simpler to work primarily with the video stream. This is
because the video stream is divided into clearly identifiable frames, while it
is more difficult to identify the exact part of the audio stream you want to
select.
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Merging Audio and Video Files
How to import an audio or video stream

Ø

Use the Merge command to merge an audio stream into a video only clip,
or a video stream into an audio clip. Make sure the streams you import are
in VDOLive compatible formats.
To merge video and audio:
1. Open a multimedia file, with only one stream (video or audio), in VDO
Clip.
2. From the File menu select Merge. The Merge With browse box opens.
3. Select the file you want to merge into your clip.
The streams are now in the VDO Clip window together.
If the audio is in an unsupported format convert the audio stream.

Converting Audio from an Unsupported Format
The only audio sampling rate compatible with VDO Clip is 8 kHz.
However, if you have audio that was captured at any other sampling rate
and you would like to compress it using VDOLive compression, a workaround exists for allowing editing and encoding of non-8kHz audio.
The following procedure uses a conversion tool called GoldWave.
GoldWave converts audio from 11, 22 or 44 kHz to 8kHz and is available
for free download via the WWW from the following address (URL):
http://web.cs.mun.ca/~chris3/goldwave/
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Ø

To convert an 11kHz audio stream:
1. Open GoldWave and use File|Open to open the .wav file.
2. From the Effects menu, select Resample.
3. Select 8,000.
4. Click OK.
5. Use File|SaveAs to save the file under a new name (16-bit, mono,
signed).
6. Merge the 8 kHz audio into your clip for use in VDO Clip.
Add +4 to +8db of Gain in GoldWave’s “Parametric EQ Filter Effect”, at
4000Hz Center and 2000Hz Width (band 7). The EQ should be applied
before resampling.

Compressing Clips
Understanding VDOLive Compression
What is compression?
Compression makes it possible for the large amounts of information in
video and audio files to be served over relatively narrow bandwidth lines,
such as those making up much of the Internet, to your audience.
VDOLive compression applies VDOnet’s VDOWave codecs to the video
and audio data; the process in which the data has these codecs
(coder/decoder) applied to them both compresses the data and encodes it,
allowing it to be decoded on the client end by a VDOLive Player.
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VDOLive compression uses standard AVI file format as a wrapper for the
compressed data.
The complete process of converting source data to VDOLive compressed
files is:

n Capture: if your content is in analog form, capture it to digital format.
n Edit: use any digital editing tool including VDOLive compression
codecs, such as Adobe Premiere™ version 4.2. You can also use VDO
Clip for editing, however, VDO Clip is primarily a compression
program. For sophisticated editing functionality, use an editing tool
such as Premiere.

n Collect information about your audience: now is the time to find out if
any of your users are restricted in the type of content they can receive,
either by limitations of bandwidth, or by a network firewall. This
knowledge will help you in selecting the appropriate encoding mode.

n Define compression settings: the most important settings are the
encoding mode and rate; you may also define other settings, such as the
interleave or key frame rate, and any settings required by the
application you are using.

n Compress: this is a completely automatic process once you have
defined the compression settings.
Once your content is compressed, it is ready to be made available to your
audience:

n Store and Serve: VDOLive compressed video files are stored on a
VDOLive Server and accessed by users from web pages. For
guidelines, refer to the separate document: Making your VDOLive
Content Available on the World Wide Web.
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n Additional step for users of the Lite VDO Plug-in: convert compressed
AVI files to AVS format. For more information, refer to pages 55, 71,
and 76 of this manual and to the separate document, Making your
VDOLive Content Available on the World Wide Web.

Compression Modes
The first parameter you must set before compressing is the mode. This
determines the type of clip you will have after compression, as expressed in
the video image quality and the video motion.

What is a Compression Mode?
The compression mode defines the relationship between the video image
quality and the speed of the motion in your compressed video. There are
four modes:

n Movie: fastest motion of all the modes, high quality images.
n Flip: slower motion than movie, but preserves high image quality.
n Storybook: no motion; still images change at pre-defined rate.
n Audio program: no motion. No video images included.

How to determine the right compression mode
Determine the mode appropriate for your work according to:

n Client firewalls considerations.
n Source data considerations, that is, the type of content you are
compressing.
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Client firewall considerations
Limitations imposed by your audience may determine the video encoding
mode you use. There are two types of compression mode available:

n VDOLive modes: to reach viewers not behind a firewall, or behind a
firewall that supports VDOLive, use the VDOLive video encoding
mode appropriate for your type of source content. Movie, Flip,
Storybook and Audio Program are all VDOLive modes.

n Lite VDO mode: to reach viewers behind a firewall that does not
support VDOLive video, you must use Lite VDO encoding. Video
encoded in this mode can reach any user. VDOLive performance is
superior to that available using Lite VDO encoding.
If your audience is viewing video from behind a network firewall, find out
whether the System Administrator has configured the network firewall to
allow VDOLive content:

n If so, use any encoding mode suitable for your content.
n If not, you must use Lite VDO encoding.
Encourage your audience to use firewalls that support VDOLive video
content.

Source content considerations
n For video content: use VDOLive Movie or Flip mode.

n For graphic, non-video content: use VDOLive Storybook mode.
n For audio content: use VDOLive Audio Program mode.
More information about when to use each mode is provided in the section
on that mode.
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Compression Rates
What is a Compression Rate?
The encoding rate defines the maximum amount of information (video
data) included in the compressed file.

n Rate is expressed in kilobits per second (kbps), which refers to the
bandwidth necessary to transmit the information.

n Information includes the color depth and speed of motion in each frame
of video.
If the user’s connection has sufficient bandwidth, s/he will receive all the
information included in a file; if not, the VDOLive Server will scale the
amount of information sent as the connection allows.

Determining the right compression rate
Here are some factors that you should take into consideration when
determining the best video encoding rate for your work:

n Viewer’s actual bandwidth: Viewers will be able to see video at the
rate allowed by their bandwidth of their connection; this will sometimes
be lower than the maximum encoding rate you set. If this happens, the
VDOLive Video Server will scale (in this case, decrease the amount of
information it sends to the user) to the user’s available bandwidth.
Should more bandwidth become available to the user during the
connection, the Server scales (now increases the amount of data being
sent to the user) accordingly.

n Video Image Quality: At higher encoding rates, more information per
frame can be included in the compressed data. Therefore, one way to
achieve good results with complex images (such as fast motion) or large
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(over 160*120 pixels) image sizes is to compress at a relatively high
encoding rate. Bear in mind, though, that in order to benefit from these
high quality video clips, your VDOLive Video Server must be able to
serve them at a high bandwidth per client allowance, and your users
must have sufficient bandwidth to receive the clips at a relatively high
speed.

n Video Motion Quality: To achieve smooth motion, a high percentage
of frames from the captured (or other source) video must be preserved
in compression. Higher encoding rates include a greater number of
frames.

n Encoding & Transfer Time: The higher the video encoding rate, the
longer it takes to compress the data and to transfer it to the VDOLive
Video Server (by FTP, for example)

n Disk Space: The higher the video encoding rate, the larger the resulting
file.

n Behavior of the VDOLive Video Server: The VDOLive Video Server
gives priority to audio data, then scales video data to the bandwidth
available in a particular connection, up to the maximum of the encoding
rate at which the file was compressed. The administrator of the
VDOLive Video Server can tell you if the Server is configured to serve
individual client connections at a rate compatible with your encoding
rate. If you compress a movie at 256 kbps, for instance, but your
VDOLive Video Server is limited to serving clients at a maximum of 64
kbps per connection, your users will not receive the full benefit of your
high compression rate files.

Additional Compression Settings
Mode and Rate settings are available to users of any version of VDO Clip
including the Trial Version; all other settings are only available to users
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with the full version of the VDOLive Tools. See the definition of the Trial
Version for additional information (page 17).

Interleave
Interleave refers to the frequency at which audio and video are integrated;
this should be about once every second.
Interleave is determined by the frame rate of the captured (input to VDO
Clip)data, not by the frame rate in the compressed result (output). For
video captured at 15 frames per second (fps), therefore, the default
interleave setting of every 10 frames is effective both for movies at which
the compressed rate may be 15 fps or higher and also for flip mode videos
where the compressed rate does not exceed 2 fps.

Key Frames
Key frames are video frames in which captured data is stored without
reference to the previous frame. These frames are used to preserve the
quality of the picture even when previous frames may have been lost; they
also require higher bandwidth for transmission since they contain more
data than other video frames.
Recommendation: work with the default setting of 1 key frame per 60
frames.

Archiving
Before compressing clips, consider preparing an archive copy. Archive
clips can be used as source material for creating new clips in the future,
recompressed at different modes and rates than those you use now.
Compress archive clips at a high encoding rate. If you have sufficient
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storage resources to save uncompressed data, archiving compressed clips is
unnecessary.

Supported Data Formats
You can use VDO Clip to compress any data that was captured with VDO
Capture. Any other captured data can also be used provided it that meets
the following requirements:

Image Size
n Width must be a multiple of 16 or compression will not succeed.
n Height must be a multiple of 16; if it is not, the frame size is rounded
down to the nearest multiple of 16 and truncated at the lower border.

n Minimum image size is 64 (w) by 64 (h) pixels.
n Maximum image size 352 (w) by 288 (h) pixels.

Color Depth
n 16 bit (RGB 555) or 24 bit (RGB 888) color depths are supported.
n 8 bit color is supported, but not recommended, for use with this version
of VDO Clip.

n

32 bit color is not supported.

Audio
Audio format must be 8 kHz, 16 bit, mono or stereo. Stereo audio can be
compressed using VDO Clip, but will be mono in the compressed version.
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Video
The video can be uncompressed, or previously compressed.
When recompressing video, consider that the quality of your results can
only be as good as the quality of the material you begin with. Both the
quality of your source material and the encoding bit rate you choose
determine the quality of compressed data.
Special Prerequisites for Storybooks
All bitmaps must be uniform supported size and color depth. If you try to
copy a bitmap into VDO Clip and it is a different size or color depth than
other bitmaps already in the clip, an error message appears.
Backward Compatibility
Video and audio data compressed using any previous versions of VDO
Clip, including the VDOLive Personal Tools 1.0 or earlier, can be decoded
and played using this version of VDO Clip.

Video Modes
Compression modes for files with video data are:

n Movie mode
n Flip mode
n Lite VDO encoding mode
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VDOLive Movies
What is a VDOLive Movie
VDOLive Movies provide full motion video to users. These movies are
created from high quality captured video and audio data, compressed at
higher video encoding rates than other VDOLive videos and bring high
quality color and motion video to your users.
When to use Movie Mode
Movie Mode works best when your viewers are Internet users with
connections of 28.8 kbps or faster, or when the movies are going to be
played over a LAN or Intranet, when each user generally has a relatively
high bandwidth connection.
The real speed at which your compressed video is transmitted will be
determined by the following factors:

n The user’s actual network bandwidth at time of viewing.
n The maximum video encoding rate you set.
n The maximum allowed bandwidth per client connection of your
VDOLive Video Server.
Compressing VDOLive Movies
Before beginning, you must have captured audio and/or video data in .avi
file format.

Ø

To compress data in movie mode:
1. Open an .avi file (File|Open)
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2. From the File menu select Driver Options. The Compression Options
dialog box opens. From here you will define compression settings for
the video data in your clip.

Figure 5 - VDO Clip Compression Options, video stream selected

3. In the list box, select the video stream.
4. Check the box next to Interleave. The default setting of every 10 frames
usually provides best results, but you can change the Interleave setting
here. (More information about Interleave: page 58)
5. Click on Options. The Video Compression dialog box opens:
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Figure 6 - VDO Clip Video Compression, VDOLive video compressor selected

6. From the list box, select the VDOLive video compressor: VDOnet
VDOWave (Scalable).
7. Check the box next to Key Frame Every. The default setting of 60
frames usually provides best results, but you can change the Key Frame
setting here. (More information about Key Frames: page 58)
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8. Click on Configure. The Compression Configuration window opens:

Figure 7 - Compression Configuration, Movie Mode selected

9. In the Mode column, click on the radio button next to Movie.
10. Set the Video Encoding Rate slider to the appropriate speed by typing a
number in the box at the bottom of the slider or by using your mouse to
move the bar to the desired point on the slider. (Video Encoding rate
explained in section on Compression Rates: page 56)
The audio encoding rate is set automatically and is not user configurable.
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11. Click OK through 2 boxes (Compression Configuration, Video
Compression) to return to the Compression Options dialog box; this
time use it to define compression settings for the audio data.
12. From the list box, select the audio stream.
13. Click on Options. The Sound Selection dialog box opens:

Figure 8- VDO Clip Sound Selection, VDOLive audio compressor selected

14. In the Format list box, select the VDOLive audio compressor:
VDOWave I.
15. In the Attributes list box, select 8,000 Hz, 16 bit, mono.
16. Click OK through 2 boxes to return to the main VDO Clip window.
17. From the File menu, select VDOEncode.
18. Name the file to which your compressed clip should be saved, and click
OK.
19. Compression begins. When compression is complete, you will be
prompted to load the MCI Player to view your clip; this is optional.
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Flip Mode Videos
What is a Flip Mode Video?
Flip Mode enables you to create high-quality videos for users with limited
bandwidth. Since these users cannot receive all the data necessary to see
full motion and high quality images, using this mode assigns priority to
image quality and reduces motion. Use the same captured video for
creating Flip Mode videos as you would for creating VDOLive Movies.
When to use Flip Mode
Use Flip Mode to compress your videos when:

n You expect your audience to be Internet users with modem connections
from 14.4 kbps-28.8 kbps.

n You assign a higher relative priority to video image quality than to
motion.
Following are the technical specifications that make this mode different
from movie mode:

n Frames of your compressed video will be shown at the highest possible
quality allowed by:

n the user’s available bandwidth, and
n the maximum allowed bandwidth per client connection of your
VDOLive Video Server.
n Flip mode allows a maximum of 2 frames per second (fps).

n Frames of the captured video are dropped during encoding
(compression) to accommodate the 2 fps maximum transmission rate
for this mode. The reduced number of frames also ensures higher image
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quality in each frame. The encoder selects which frames to drop; this is
not user-configurable.
Since most users, even those with high-speed connections, have limited
bandwidth, there is a tradeoff between motion and image quality that
determines what data gets through to the viewer and what data is lost. If
motion is your highest priority for video, then compress in Movie mode. If
you are willing to reduce motion in order to send higher quality images, use
Flip mode.

Compressing Flip Mode Videos
Compressing flip mode videos is the same as compressing VDOLive
movies, except that you select flip from the mode column in the
Compression Configuration window.

Ø

To compress flip mode videos:
1. Open an .avi file (File|Open)
2. From the File menu select Driver Options. The Compression Options
dialog box opens. From here you will define compression settings for
the video data in your clip.
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Figure 9- VDO Clip Compression Options, video stream selected

3. In the list box, select the video stream.
4. Check the box next to Interleave. The default setting of every 10 frames
usually provides best results, but you can change the Interleave setting
here. (More information about Interleave: page 58)
5. Click on Options. The Video Compression dialog box opens:

Figure 10 - VDO Clip Video Compression, VDOLive video compressor selected
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6. From the list box, select the VDOLive video compressor: VDOnet
VDOWave (Scalable).
7. Check the box next to Key Frame Every. The default setting of 60
frames usually provides best results, but you can change the Key Frame
setting here. (More information about Key Frames: page 58)
8. Click on Configure. The Compression Configuration window opens:

Figure 11 - Compression Configuration, Flip Mode selected

9. In the Mode column, click on the radio button next to Flip.
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10. Set the Video Encoding Rate slider to the appropriate speed by typing a
number in the box at the bottom of the slider or by using your mouse to
move the bar to the desired point on the slider. (Video Encoding rate
explained in section on Compression Rates: page 56)
11. Click OK through 2 boxes (Compression Configuration, Video
Compression) to return to the Compression Options dialog box; this
time use it to define compression settings for the audio data.
12. From the list box, select the audio stream.
13. Click on Options. The Sound Selection dialog box opens:

Figure 12- VDO Clip Sound Selection, VDOLive audio compressor selected

14. In the Format list box, select the VDOLive audio compressor:
VDOWave I.
15. In the Attributes list box, select 8kHz, 16 bit, mono.
The audio encoding rate is set automatically and is not user configurable.
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16. Click OK through 2 boxes to return to the main VDO Clip window.
17. From the File menu, select VDOEncode.
18. Name the file to which your compressed clip should be saved, and click
OK.
19. Compression begins. When compression is complete, you will be
prompted to load the MCI Player to view your clip; this is optional.

Lite VDO Movies
What is a Lite VDO Movie?
Lite VDO movies create AVI files that can be converted to VDOLive AVS
file format and served directly from an HTTP (Web) Server. These files
can be received by any user and so provide a way of reaching audiences
behind firewalls that do not allow VDOLive content.
When to use Lite VDO Mode
Use Lite VDO to compress your videos when:

n Your audience is viewing video from behind a firewall that does not
allow VDOLive video. The quality of VDOLive video is superior to
that of Lite VDO movies, so use Lite VDO only when necessary to
reach this audience.
Users behind a firewall whose System Administrator has allowed
VDOLive video, or whose firewall supports VDOLive video, can see
VDOLive video compressed in any mode and do not require Lite VDO.
Following are the technical specifications that make this mode different
from VDOLive modes:

n Maximum encoding rate of 128 kbps.
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Compressing Lite VDO Movies
To compress Lite VDO movies:

Ø

1. Open an .avi file (File|Open)
2. From the File menu select Driver Options. The Compression Options
dialog box opens. From here you will define compression settings for
the video data in your clip.

Figure 13- VDO Clip Compression Options, video stream selected

3. In the list box, select the video stream.
4. Check the box next to Interleave. The default setting of every 10 frames
usually provides best results, but you can change the Interleave setting
here. (More information about Interleave: page 58)
5. Click on Options. The Video Compression dialog box opens:
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Figure 14 - VDO Clip Video Compression, VDOLive video compressor selected

6. From the list box, select the VDOLive video compressor: VDOnet
VDOWave (Scalable).
7. Check the box next to Key Frame Every. The default setting of 60
frames usually provides best results, but you can change the Key Frame
setting here. (More information about Key Frames: page 58)
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8. Click on Configure. The Compression Configuration window opens:

Figure 15 - Compression Configuration, Lite VDO mode selected

9. In the mode column, click the radio button in the Lite VDO mode box,
next to Lite VDO.
10. Set the Video Encoding Rate slider to the appropriate speed by typing a
number in the box at the bottom of the slider or by using your mouse to
move the bar to the desired point on the slider. (Video Encoding rate
explained in section on Compression Rates: page 56)
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The video encoding rate slider is limited to a maximum of 128 kbps in Lite
VDO mode.
11. Click OK through 2 boxes (Compression Configuration, Video
Compression) to return to the Compression Options dialog box; this
time use it to define compression settings for the audio data.
12. From the list box, select the audio stream.
13. Click on Options. The Sound Selection dialog box opens:

Figure 16- VDO Clip Sound Selection, VDOLive audio compressor selected

14. In the Format list box, select the VDOLive audio compressor:
VDOWave I.
15. In the Attributes list box, select 8kHz, 16 bit, mono.
The audio encoding rate is set automatically and is not user configurable.
16. Click OK through 2 boxes to return to the main VDO Clip window.
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17. From the File menu, select VDOEncode.
18. Name the file to which your compressed clip should be saved, and click
OK.
19. Compression begins. When compression is complete, you will be
prompted to load the MCI Player to view your clip; this is optional.

Creating AVS files from Lite VDO Movies
Once you have created Lite VDO Movies, you must convert them to AVS
format for serving from a Web (HTTP) Server. Regular VDOLive
compressed AVI files can be served only from a VDOLive Server, not
from a Web server.

Ø

To convert Lite VDO Movies to AVS files:
1. Open the Converter tool from the VDOLive Tools folder or program
group.
2. Type in or use the Browse button to enter the name of the Lite VDO
Movie in the Input Filename box.
3. Type in or use the Browse button to enter the name of the AVS file to
be created from the Lite Movie.
4. Click the Convert button.
Refer to the separate document Making your VDOLive Content Available
on the World Wide Web for more information about storing and serving
AVS files from a Web (HTTP) Server and for instructions on using the
Converter for creating AVS content from VDOLive AVI files.
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Audio / Graphic (Non-Video) Modes
In VDO Clip’s Storybook and Audio Program modes, the source material
you are working with will be still graphic images, usually bitmap files, and
not AVI files. Therefore, functions such as opening an AVI file or editing
video data are not relevant to these modes. For information about editing,
refer to the section beginning on page 48.

Audio Programs
What is an Audio Program?
Audio Programs are files of compressed audio. They include, and are
limited to, one graphic image at the beginning of the clip.
When to use Audio Programs
n Create audio programs whenever you have only audio content.

n The graphic image at the beginning can be a picture, corporate logo or
any other image and is displayed throughout the Audio Program.

n The graphic must be pasted into the clip.
n The format of your source audio must be 8 kHz, 16 bit, mono.
Radio programs are easily adapted to this format, as are audio clips you
use to explain your products or services. Additional uses of this format
include interviews, training instructions, press releases and news.
Compressing Audio Programs
You must paste one graphic image at the beginning of an Audio Program.
Included with the VDOLive Tools is a file containing one frame of video,
named vdologo.bmp. You can use vdologo.bmp, or any other graphic as
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the one required frame in your Audio Program. The procedure below uses
vdologo.bmp as an example. You can find vdologo.bmp in the program
folder to which you installed the VDOLive Tools.
To compress your audio content with additional graphics, use Storybook
Mode.

Ø

To create and compress an audio program:
1. Open VDO Clip.
2. From the Play menu, select Video Rate Control. The Compression
Configuration window opens:
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Figure 17 - Compression Configuration, Audio Program mode selected

3. In the mode column, click the radio button next to Audio Program.
The video encoding rate slider is disabled in this mode; the encoding rate is
set automatically for audio programs.
4. Click OK to return to the main window of VDO Clip.
5. Open vdologo.bmp in a graphics program. (such as Paint™, from
Windows 95 Accessories)
6. Copy vdologo.bmp to the Clipboard.
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7. Return to VDO Clip.
8. Select Paste from the Edit menu of VDO Clip. Your image appears as
one frame in the video stream.
9. Select File|Merge. The Merge With dialog box opens.
10. Browse for, or enter the name of, an audio only file in .avi or .wav
format and click Open. The audio stream appears in your clip.
If you are copying an images from any program other than Paint™ and it
won’t paste into VDO Clip, try first pasting into Paint™ and then to VDO
Clip.
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Figure 18 - VDO Clip, with one bitmap and an audio stream
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11. Select Edit|Info. The Info dialog box opens:

Figure 19 - VDO Clip Stream Info window

12. In the Name box at the bottom of the Info window, enter the name for
the video (one frame) and audio streams of your Audio program, then
click OK to return to the main window of VDO Clip.
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13. From the File menu, select VDOEncode.
14. Name the file to which your compressed clip should be saved, and click
OK.
The Interleave and Key Frame settings do not matter for an audio program.
Should you wish to use SaveAs to compress the Audio Program, be sure to
use Driver Options to select the VDOLive codecs for both video and audio.

Storybooks
What is a Storybook?
Storybook Mode produces clips of graphic images (not video), with or
without an audio stream and is intended for use when your viewers are
Internet users with low bandwidth connections, such as 14.4 kbps modems,
or when your content is graphic, not video.
You define the interval for which each graphic will be displayed and, if you
are synchronizing the pictures with audio, coordinate the changing pictures
with the audio content.
Storybook clips have no motion. They can display up to 2 frames per
second to viewers, but work best when set to display one frame every 10
seconds or more.
Graphics used for Storybook clips must be uniform in their size and in
their color depth, in addition to being in sizes and color depths supported
by VDOLive compression. (see page 59 for supported formats).
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Using a video editing tool, such as Adobe Premiere™ (version 4.2) or
Ulead’s Media Studio™, is the easiest way to create storybooks, however,
procedures for creating storybooks using VDO Clip for editing are also
described in the following section.

When to use Storybook Mode
Storybooks are intended for users with low bandwidth Internet connections,
and are different from VDOLive movies or flip mode videos in that
storybooks use only graphics files as input, not video content.
Your viewers will see every frame of the content compressed in this mode;
no frames will be dropped during transmission because of Server scaling.
Additionally, the VDOLive Video Player displays a message telling
viewers they are seeing a storybook. Create storybooks, and compress in
Storybook mode when:

n Your content is still graphic images, not video.
n Your users have low-bandwidth Internet connections, such as 14.4 kbps
modem connections.
Possible uses of this mode are for any training or marketing presentation,
an “art gallery” storybook file, where you show still images of paintings or
art pieces, with or without an accompanying musical track or narration, or
for an online illustrated book, with the accompanying narration.
Creating and Compressing Storybooks
Two steps are involved in creating the material for your storybook before
you compress:
1. Assembling all your images either in VDO Clip, or in a video editing
program such as Adobe Premiere™ (4.2) or Ulead’s Media Studio™.
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2. Synchronizing the images with the audio and determining the length of
time for which each image will be shown.
You will achieve best results when you set a display interval of one frame
every 10 or more seconds.
Following are two methods for creating and compressing storybooks. The
first uses VDO Clip both as the editing tool and for compression, and the
second uses Adobe Premiere™ version 4.2 with VDOLive compression.

Using VDO Clip
In this method you define the frequency with which you want the graphic
images to change.
With VDO Clip on Windows 95

Ø

To create and compress a storybook using VDO Clip:
1. Open VDO Clip.
2. From the Play menu, select Video Rate Control. The Compression
Configuration window opens.
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Figure 20 - Compression Configuration, Storybook mode selected

3. Click on the radio button next to Storybook in the Mode column.
The video encoding rate slider is disabled in this mode; both the video and
audio encoding rates are selected automatically.
4. Click OK to return to the main window of VDO Clip.
5. Paste graphic images from any graphics application in to VDO Clip
(Edit|Paste).
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Make sure all the images are in a supported and uniform size and color
depth. (see page 59 for supported formats).
6. Use Merge (page 51) to add an audio stream to your clip. Check that
the audio stream is in a supported format.
7. Optional: Name the two streams. Select Edit|Info. Select the stream
names from the list box at the top of the Info window and enter a name
for each in the dialog box at the bottom of the Info window.
8. Select Info from the Edit menu. The Stream Info dialog box opens:
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Figure 21 - VDO Clip, Stream Info window

Define duration, the length of time in seconds for which each frame
will be displayed, by setting the Scale and Rate as follows:
Duration per frame, in seconds = Scale/Rate
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For example, to display each frame for ten seconds, enter 10 in the
Scale box and 1 in the Rate box.
If you determine that a storybook will display at a rate of one frame each
10 seconds, for example, and then you want to display certain frames for
longer, replicate those frames and insert them as many times as needed. For
example, to display one picture for 30 seconds in a storybook with a rate of
one frame per 10 seconds, insert that frame 3 times in a row in the video
stream.
9. From the File menu, select Driver Options. The Compression Options
dialog box opens:

Figure 22 - VDO Clip Compression Options dialog box

10. Check the box next to Interleave and change the setting from every 10
frames (the VDO Clip default) to every 1 frame. Click OK to return to
the main window of VDO Clip.
11. Select VDOEncode from the File menu; a browse box opens. Name the
file to which compressed data should be saved and click OK.
Compression begins, and stops automatically when complete.
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With VDO Clip on Windows NT

Ø

To create and compress storybooks using VDO Clip on Windows NT:
1. In Paint™ or any other graphics program, open vdologo.bmp (or any
other bitmap).
2. Select Copy. In Paint™ for Windows NT, you must first outline the
image using the pick tool.
3. Open the ClipBook Viewer (from Main).
4. From the Edit menu of the Local ClipBook Viewer, select Paste.
5. Enter a page name.
6. From the Window menu, switch to the Clipboard window.
7. From the View menu, check the DIB Bitmap option.
8. Switch to VDO Clip and paste vdologo.bmp (Edit|Paste).
9. In the File menu, check that VDOEncode is enabled. If it is not,
vdologo.bmp may have been truncated when it was selected for
copying. If the width of vdologo.bmp or any other bitmap you are using
is not evenly divisible by 16, then the bitmap cannot be used for
VDOLive compression.
10. Repeat this procedure for each bitmap.
Create the rest of the audio program or storybook as you would under
Windows 95.

Creating and compressing a storybook using Adobe Premiere™
In this method you define the amount of time for which each frame will be
displayed.
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Ø

To create and compress a storybook using Adobe Premiere™ version 4.2:
Make sure that the audio format is supported by VDOLive compression,
that the images are in a size and color format supported by VDOLive
compression and that all the images are the same size and in the same color
format as each other. (For information about sizes and colors supported by
VDOLive Compression see page 59.)
1. Import (File|Import) graphic images and audio stream into your Project
Window.
2. Move the audio stream and images from the Project Window into the
Construction Window. You can either set the duration for each image as
you move it, or adjust the duration by dragging the right border of the
images.
3. Open the Make Movie dialog box (Make|Make Movie)
4. In Output Options|Type, select VDOnet VDOWave I for audio
compression.
5. In Output Options|Type, set Interleave to every 8 frames. Click OK to
return to the Make Movie dialog box.
6. In Make Movie|Compression, select the Method: VDOnet VDOWave
(Scalable).
7. Click Configure and select Storybook mode. Click OK to return to the
Compression Settings dialog box.
8. Make sure the Optimize Stills option is deselected (unchecked).
9. In Compression Settings|Special Processing|Settings, make sure the
Better Resize option is deselected (unchecked). Return to the
Compression Settings dialog box.
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10. In Options, set frames per second to 1.
11. In Options, set the key frames to every 1 frame. Click OK to return to
the Make Movie dialog box.
12. Name the file.
13. Save.
If you have trouble playing audio programs using the MCI Player, and you
created the clips using Adobe Premiere, check that the length of the video
stream is set to the same duration as the duration of the audio stream. Do
this by setting the duration in the Construction Window. In the
Compression Settings window, make sure the frame rate is set to 1 frame
per second.
Define a “preset” of all the relevant settings for using VDOLive
compression with Adobe Premiere™. Only version 4.2 of Premiere
includes VDOLive compression.

About VDOEncode
VDOEncode selects the VDOLive VDOWave compressors for audio and
video data. If you are using this compression mode, you do not have to
select the VDOLive codecs from Driver Options, however, you still have to
define appropriate key frame, interleave, mode and rate settings.
Before you begin compression using VDOEncode, make sure that:

n Your data is uncompressed. To compress previously compressed data,
use SaveAs.
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n The file is in a format supported by VDOLive compression; if either the
audio or the video data is in an unsupported format, VDO Encode is
disabled.

n Encoding settings (including key frames, interleave and mode, as well as

Ø

rate where applicable) have been configured; if they haven’t, the
compressor will use the last settings.
To compress using VDOEncode:
1. Open the .avi file you want to compress, if it is not already open.
2. Choose VDO Encode.
3. When prompted, name the output file for the compressed data.
Compression begins, and stops automatically when complete.
4. Exit using the ESC key.

Saving and Closing Clips
Saving data is part of the compression process and, whether you use
SaveAs or VDOEncode, you are prompted to name the output file in which
to save the compressed data.
Use SaveAs to:

n To save files of uncompressed or previously compressed data,
according to the driver settings.

n To save edited and unedited versions of the same clip under different
file names.

n To compress using non-VDOLive compressors.
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Saving Uncompressed Data

Ø

You may want to save data uncompressed if, for example, you used VDO
Clip only to remove empty space from a file (see pages 29 and 31 in the
section on Allocating File Space for more information), or only to edit data.
To save uncompressed data:
1. Select File|Driver Options to check that the Compressor selected for the
video stream is Full Frames, Uncompressed.
2. Select File|Driver Options to check that the Format selected for the
audio stream is the same as in the original clip.
3. Use SaveAs to name the file and save it.

Saving Compressed Data
Saving Data without Recompressing
If you opened an .avi file with data previously compressed using VDOLive
or any other compression, and want to resave it without recompressing,
use the following procedure.
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Ø

To save compressed data without recompression:
1. Select File|Driver Options. In the Compression Options box, select the
video stream and click on the Options button.
2. In the Video Compression box, check that the Compressor selected is
No Recompression. Click OK to return to Compression Options.
3. Select the audio stream and click on the Options button.
4. In the Sound Selection dialog box, check that the Format is the same as
in the original clip.
5. Check that the Interleave setting is the same as in the clip when you
opened it. If it isn’t, re-check the Interleave check box or change the
number in the Interleave box.
6. Use SaveAs to name the file and save it.

Saving Data with Recompressing
You will achieve best results using VDO Clip and the VDOLive codecs
when you use uncompressed data. However, you can use VDO Clip to save
and recompress previously compressed data. Examples of situations in
which you might want to do this are:

n You don’t have the original, uncompressed version of a clip.
n Your capture card output is compressed video.
The following conditions are required in order for VDO Clip to
recompress:

n You must have the decompressor appropriate to the format in which the
material was previously compressed. For example, if a clip was
previously compressed using the Indeo® (Intel) codec, you must have
this codec installed on your system in order for recompression to work.
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n The video and audio data must be in formats supported by VDOLive
compression. See page 59 for supported formats; page 51 for ways to
convert audio from an unsupported format.
Use File|Properties|Details to find out the compression format of a clip.
You can find out what video and/or audio codecs are installed on your
system by using Control Panel|Multimedia|Advanced|Video Compression
Codecs –or– Audio Compression Codecs

Ø

To save compressed data and recompress it:
1. Select File|Driver Options. In the Compression Options box, select the
video stream and click on the Options button.
2. In the Video Compression box, select the driver you want to use for
compression. It can be the VDOLive video codec or any other. Click
OK to return to Compression Options.
3. Select the audio stream and click on the Options button.
4. In the Sound Selection dialog box, select the Format in which you want
to compress the data. It can be VDOLive format or any other.
5. For VDOLive compression, use the default key frame setting of every
60 frames and set interleave to every 10 frames. For compression using
another codec, use settings appropriate to that codec.
6. Use SaveAs to name the file and save it.
If you cannot find the VDOLive video/audio codecs in the appropriate
Driver Options list box, your clip may be in a format unsupported by
VDOLive compression.
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Saving and Compressing using a non-VDOLive Compressor

Ø

You can compress using a non-VDOLive compressor via the Save As
Option.
To begin compression using Save As:
1. Open the .avi file you want to compress.
2. From the File menu, select Driver Options. The Compression Options
box opens.
3. Select the compressor you want to use, and make any other changes you
want to the compression settings.
4. Select File|SaveAs.
5. Enter the file name and path and click OK. Compression begins, and
stops automatically when complete.

Closing a File

Ø

To close a file:
1. Select Close from the File menu.

Testing Clips
Using Local Playback
You can test the video image quality of any VDOLive clip by playing it
using the Windows Media Player. However, this will not accurately
represent what users will see when viewing the same clip over a network,
from a VDOLive Server.
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Using Playback from VDO Clip
For VDOLive Movies, you can also use the Playback function of VDO
Clip to simulate playback of the clip at different speeds. Because all other
modes have built-in limits on their speed, this function is not useful for
clips compressed in other modes.

Ø

When you use the Playback function, you are playing video from your
local disk or network, but not via a VDOLive Video Server. Generally,
viewers will have to contend with a higher level of network traffic than
your Playback conditions, and the VDOLive Video Server will scale
according to the actual bandwidth of each viewer's connection.
To use Playback to test a VDOLive Movie:
1. Open a clip.
2. Open the Playback page (Play|Video Rate Control|Playback).
3. Set the rate you wish to simulate, using the Playback rate slider.
4. Play the clip.

Using the VDOLive Player

Ø

You can use the VDOLive Player in standalone mode to test compressed
VDOLive clips. The clips must first be uploaded to the VDOLive Server.
To use the VDOLive Player to test playback quality of compressed clips:
1. Open the VDOLive Player and click on the Play button. A dialog box
opens.
2. Enter the complete location and name of the file you are testing.
vdo://VDOLiveServerHostName|Server IP
address[:Server port]/FileNameOnServer.avi
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For additional information, about using the VDOLive Player for testing
clips, and for information on testing AVS clips, refer to the separate
document: Making your VDOLive Content Available on the World Wide
Web.

Exiting the Compression Tool

Ø

Before exiting VDO Clip, be sure to save open files.
To exit VDO Clip:
1. Choose Exit from the File menu.
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Appendix A: Troubleshooting Your Capture Equipment
The following is a short checklist of some common hardware problems and
solutions related to use of VDO Capture.

No picture in VDO Capture
Check your video source:

n Signal. Possible signals are NTSC, PAL and SEACAM. Make sure
you are set to the right signal.

n Input. Check if your video input settings match your equipment
connections, composite or S-VHS.

n Quality of source. Try playing the video on different equipment, or
viewing it on a different screen. If the quality is still poor, the video tape
may be damaged. Flaws in the original video show up in captured data.

No audio and no video in VDO Capture
n Check all your hardware connections including proper connection to
power source.

n Are the video out ports of your video source connected properly to the
capture card?

n Are the sound and video cards installed properly? Check IRQ and DMA
settings for conflict with other devices. Refer to the relevant
documentation for information on these settings.

Video, but no audio in VDO Capture
n Check audio source and speakers
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n Is there a volume control you can use to turn up the sound level?
n Is there a sound, mixer or control panel software device? Try adjusting
the volume from there.

n Are you using S-Video? If so, you must use separate cables to carry the
audio.

n Check to see that speakers are properly connected.

Audio, but no video in VDO Capture
n Check that your Video Source is set accurately. (in VDO Capture,
Options|Video Source) If you are not sure which signal you are using, try
each (S-Video or Composite) and see which works.
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